Reset Search
 

 

Article

4656 - Attempting to upgrade the vTM-VA failed with the message "The upgrade process has encountered an error and cannot continue. Please contact your support provider to help you fix this problem."

« Go Back

Information

 
Last Modified Date11/27/2017 4:10 PM
Synopsis
This article describes an issue where upgrading vTM fails with the message "The upgrade process has encountered an error and cannot continue. Please contact your support provider to help you fix this problem."
Problem or Goal
When attempting to upgrade the vTM failed with the message:
The upgrade process has encountered an error and cannot continue. 
Please contact your support provider to help you fix this problem.

A review of the /support/appliance/upgrade log, the following shows

Running postinst hook script /usr/sbin/update-grub.
Failed to find grub device for /dev/hda1
User postinst hook script [/usr/sbin/update-grub] exited with value 255
dpkg: error processing linux-image-2.6.24-amd64-vmware-generic (--install):
subprocess post-installation script returned error exit status 255
Setting up zxtm-90 (90r2-60373) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
linux-image-2.6.24-amd64-vmware-generic
Attempting upgrade Stingray software 9.0->9.0r3: Tue Nov 13 17:13:32 EET 2012
dpkg: error processing packages/*.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
packages/*.deb
Cause
Solution
The vTM upgrade file attempts to load the installation file from the /sda partition. If the default Hypervisor grub device points to /hda then this particular problem can result. Changing the reference from /dev/sda in the /boot/grub/device.map to /hda resolved the issue.

 

Related Links
Attachment 1 
Created ByVenkataKondaReddy Palem

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255