Reset Search
 

 

Article

KB40403 - Java Secure Application Manager (JSAM) no longer launches with Firefox in 8.2R5 and above with error message: "Your browser does not support Java Applet. Please use other supported browsers to launch Java Applet based applications."

« Go Back

Information

 
Last Modified Date4/24/2017 7:35 PM
Synopsis
This article describes an issue where JSAM fails to launch using Firefox browser after upgrading the PCS OS version to 8.2R5 and up with the error message: "Your browser does not support Java Applet. Please use other supported browsers to launch Java Applet based applications."
Problem or Goal
After upgrading to 8.2R5 and above, JSAM fails to launch in Firefox browser with the following error message displayed:  
 
Your browser does not support Java Applet. Please use other supported 
browsers to launch Java Applet based applications.

User-added image
Cause
Starting in PCS OS 8.2R5, Java Secure Application Manager (JSAM) support has been removed from Firefox.
Solution
Beginning with Firefox 52, NPAPI plugin support will be limited to Flash support.  Java plug-in will no longer be supported.  Due to this change, JSAM and any additional Java Applet client delivery options for PCS application access that rely on Java plug-in support will no longer work with Firefox 52+.  For more information, please refer to https://java.com/en/download/help/firefox_java.xml.

As a proactive step, Pulse Secure blocked Java (including JSAM) for Firefox browsers starting in PCS OS 8.2R5 to 8.2R7.  With the release of 8.2R8 (tentative for end of May 2017), the block was removed and end users are able to launch JSAM for Firefox 52.X Extended Support Release (ESR) and previous versions of Firefox that still support the Java plugin.
Related Links
Attachment 1 
Created ByLokesh T K

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255