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KB40721 - Pulse Secure Application Launcher (PSAL) continues to receive a warning prompt after selecting Always

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Last Modified Date9/19/2017 12:00 AM
Synopsis
This article describes an issue where end users continue to receive a warning prompt for "Do you want to allow Pulse Secure to contact the server?" after selecting Always from a previous connection.
Problem or Goal
During the initial connection to the PCS / PPS device, an end user will receive a warning prompt:
Do you want to allow Pulse Secure to contact the server?
If the end user selects Always, the server name will be added to the whitelist file.  The expected behavior would be the end user no longer receives the warning prompt unless the whitelist file is removed.  However, any future connections will continue receive the warning prompt.
Cause
This issue occurs due to an issue where whitelist file remains in a older directory.  This is applicable when all conditions are met:
  • Applicable to any Windows OS version
  • Missing the C:\Users\<username>\AppData\Roaming\Juniper Networks directory
This issue would be applicable to the following releases:
  • 8.2R1 to 8.2R8
  • 8.3R1 to 8.3R2
Solution
This issue is resolved in 8.3R2.1. 8.2R9 is tentative for the end of September.

​Workaround:

  • Manually create "Juniper Networks" directory in C:\Users\<username>\AppData\Roaming directory.  Once the end user has selected Always option, whitelist.txt will be created in the Juniper Networks directory.
Related Links
Attachment 1 
Created ByK. Kitajima

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