Reset Search
 

 

Article

KB40752 - Support for macOS High Sierra (10.13) and known issues

« Go Back

Information

 
Last Modified Date11/10/2017 8:40 AM
Synopsis
This article provides compatibility details of macOS (10.13) High Sierra with Pulse Secure products
Problem or Goal
Cause
Solution

Will Pulse Secure add macOS High Sierra to its list of supported client list?

Yes. Pulse Secure has qualified macOS High Sierra with various beta releases, GM release and public release. Pulse Secure completed compatibility testing (refer to the known issues below) for Pulse Connect Secure 8.3R3 and Pulse Secure Desktop client 5.3R3.

As of July 11, 2017, Pulse Secure Desktop client 5.2 and Pulse Connect Secure 8.2 has reached end of engineering. In an effort to minimize customer and end user impact, Pulse Secure has completed compatibility testing for the following releases:
  • Pulse Secure Desktop client 5.2R9
  • Pulse Connect Secure 8.2R9
Pulse Desktop 5.2R9 are available now for download at Pulse Secure Licensing and Download Center.

Note:  Software downloads are only available to Pulse Secure administrators with a valid service contract.  End users should contact their Pulse Secure administrator or IT Help Desk to obtain the latest software.

What is the difference between compatible and qualified releases?

  • Qualified release means Pulse Secure QA has performed full regression testing cycles against the specific release. 
  • Compatible release means Pulse Secure QA has performed basic functionality testing cycles against the specific release. 

Are there any major known-issues that were covered during qualification?

Currently there are no major issues that have been found in most of the common use cases such as Pulse Secure Desktop client for VPN access, Host checker related functionality for endpoint checks, etc. The minor issues found are:

  1. Unable to launch JSAM on Mac OS High Sierra if Java JDK is not installed on the client machine (PRS-356665) Typically only Java JRE software is required to launch and run Java Applets. The workaround for this issue is explained in KB40957

Note: Pulse Secure strongly recommends customer that use JSAM on MacOS to evaluate using Pulse Desktop Client instead. Various browsers and client OS have been introducing several changes around how Java based applets are launched and run which results in sub-optimal end-user experience. Pulse Desktop Client will provide a far superior end-user experience.

  1. When using the PCS HTML5 based RDP functionality via Safari browser the end-user may not see the PCS bookmark toolbar (PRS-356665). This issue may cause minor inconvenience as the end-user will not be able to go back to the PCS home page to access another resource from the bookmark page. The workaround is to open the HTML5 bookmark in a new browser window or tab so they don't have to rely on the bookmark toolbar. Pulse Secure is investigating this issue. 

  2. Safari 11 is unable to launch Pulse Secure components (i.e. Pulse Secure Desktop client, Host Checker, etc) with Pulse Secure Application Launcher (PSAL) due to the Allow prompt quickly disappearing (PRS-357797). The workarounds for this issue are provided in KB41052


Is Network Connect support on macOS High Sierra?

Network Connect is not supported on Mac 10.9 and later, please use Pulse Secure Desktop Client instead. 

Related Links
Attachment 1 
Created ByK. Kitajima

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255