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14120 - Audit log message for pool node changes made via REST API do not include the IP of the node that was changed

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Last Modified Date4/11/2018 5:42 PM
Synopsis
This article describes an issue where the audit log for pool node changes made via REST does not show which nodes are changed.

 
Problem or Goal
If a pool node is modified from the UI, the details in the audit log include the node IP address that the change was made on.  

For example, the following log entry is made when changing a node to "draining".:
 
[05/Jun/2014:16:40:19 +0100] USER=admin GROUP=admin AUTH=local IP=10.0.0.1 OPERATION=keymod KEY=draining VALUE=10.0.2.2 OLDVAL= FILE=Pool > pool_name


When the same change is made via REST API, the value for the node is replaced with the change made and the node IP is missing from the audit log entry: 

Example:
[05/Jun/2014:16:41:55 +0100] USER=admin GROUP=admin AUTH=local IP=10.0.0.1 OPERATION=keymod KEY=nodes_table VALUE=draining OLDVAL=active FILE=pools > pool_name
Cause
This behavior with REST API is currently expected, however a feature request has been created to change the behavior and log the same details as are logged when making the change from the UI.
Solution
The below workaround can be used to log the node in the audit log using REST API.

Use the REST "PUT" command to have the vTM respond with the config settings after the change is made. 
For example:
"nodes_table": [
{
"node": "10.0.0.1:8080",
"priority": 1,
"state": "active",
"weight": 1
},
{
"node": "10.0.0.2:8080",
"priority": 1,
"state": "active",
"weight": 1
},
{
"node": "10.0.0.3:8080",
"priority": 1,
"state": "active",
"weight": 1
}
],


Log the responses to PUT statements to show the status of the pool after the change.  
Related Links
Attachment 1 
Created ByVenkataKondaReddy Palem

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