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KB17030 - Unable to download current patch management data or virus signature from download.pulsesecure.net due to SSL certificate problem

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Last Modified Date12/29/2015 2:33 AM
Synopsis

Unable to download current patch management data or virus signature from download.pulsesecure.net due to SSL certificate problem

This article describes the issue of the SSL CERT error being generated, when downloading updates from download.pulsesecure.net.

The updates include:
  • Current virus signature list
  • Updated patch management data
Problem or Goal
The event log displays the error as 'SSL certificate problem, verify that the CA cert is OK'.
Error Message: SSL certificate problem, verify that the CA cert is OK
PCS - [127.0.0.1] Root::System()[] - Unable to download current patch management data from 
'https://download.pulsesecure.net/software/hc/patchdata/patchdata.dat'. 
Reason: SSL Certificate Problem, verify that the CA cert OK.
Cause
This issue occurs due to the Pulse Connect Secure or Pulse Policy Secure device missing the correct certificate authority under Trusted Server CAs.
Solution
To resolve this problem, ensure all the required Root CA are added to the Trusted Server CAs list for https://download.pulsesecure.net.

Copy the certificate below and save as a text file with an extension .crt
 
-----BEGIN CERTIFICATE-----
MIIEADCCAuigAwIBAgIBADANBgkqhkiG9w0BAQUFADBjMQswCQYDVQQGEwJVUzEh
MB8GA1UEChMYVGhlIEdvIERhZGR5IEdyb3VwLCBJbmMuMTEwLwYDVQQLEyhHbyBE
YWRkeSBDbGFzcyAyIENlcnRpZmljYXRpb24gQXV0aG9yaXR5MB4XDTA0MDYyOTE3
MDYyMFoXDTM0MDYyOTE3MDYyMFowYzELMAkGA1UEBhMCVVMxITAfBgNVBAoTGFRo
ZSBHbyBEYWRkeSBHcm91cCwgSW5jLjExMC8GA1UECxMoR28gRGFkZHkgQ2xhc3Mg
MiBDZXJ0aWZpY2F0aW9uIEF1dGhvcml0eTCCASAwDQYJKoZIhvcNAQEBBQADggEN
ADCCAQgCggEBAN6d1+pXGEmhW+vXX0iG6r7d/+TvZxz0ZWizV3GgXne77ZtJ6XCA
PVYYYwhv2vLM0D9/AlQiVBDYsoHUwHU9S3/Hd8M+eKsaA7Ugay9qK7HFiH7Eux6w
wdhFJ2+qN1j3hybX2C32qRe3H3I2TqYXP2WYktsqbl2i/ojgC95/5Y0V4evLOtXi
EqITLdiOr18SPaAIBQi2XKVlOARFmR6jYGB0xUGlcmIbYsUfb18aQr4CUWWoriMY
avx4A6lNf4DD+qta/KFApMoZFv6yyO9ecw3ud72a9nmYvLEHZ6IVDd2gWMZEewo+
YihfukEHU1jPEX44dMX4/7VpkI+EdOqXG68CAQOjgcAwgb0wHQYDVR0OBBYEFNLE
sNKR1EwRcbNhyz2h/t2oatTjMIGNBgNVHSMEgYUwgYKAFNLEsNKR1EwRcbNhyz2h
/t2oatTjoWekZTBjMQswCQYDVQQGEwJVUzEhMB8GA1UEChMYVGhlIEdvIERhZGR5
IEdyb3VwLCBJbmMuMTEwLwYDVQQLEyhHbyBEYWRkeSBDbGFzcyAyIENlcnRpZmlj
YXRpb24gQXV0aG9yaXR5ggEAMAwGA1UdEwQFMAMBAf8wDQYJKoZIhvcNAQEFBQAD
ggEBADJL87LKPpH8EsahB4yOd6AzBhRckB4Y9wimPQoZ+YeAEW5p5JYXMP80kWNy
OO7MHAGjHZQopDH2esRU1/blMVgDoszOYtuURXO1v0XJJLXVggKtI3lpjbi2Tc7P
TMozI+gciKqdi0FuFskg5YmezTvacPd+mSYgFFQlq25zheabIZ0KbIIOqPjCDPoQ
HmyW74cNxA9hi63ugyuV+I6ShHI56yDqg+2DzZduCLzrTia2cyvk0/ZM/iZx4mER
dEr/VxqHD3VILs9RaRegAhJhldXRQLIQTO7ErBBDpqWeCtWVYpoNz4iCxTIM5Cuf
ReYNnyicsbkqWletNw+vHX/bvZ8=
-----END CERTIFICATE-----
 
Once you have the certificate copied and saved, follow the below steps:
  1. Log in to Admin UI
  2. Navigate to System > Configuration > Certificates > Trusted Server CAs
User-added image
  1. Click Import CA certificate
User-added image
  1. Click Choose File, the select the text file (.crt file) you saved
  2. Click Import Certificate
User-added image

Once this is complete, retry downloading the list again.
Related Links
Attachment 1 
Created ByData Deployment

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