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KB22294 - [PCS] Unable to access Virtual desktops configured through the Virtual Desktop Resource Profile

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Last Modified Date8/1/2015 3:38 PM
Synopsis
This article describes the issue of users being unable to access virtual desktops configured through the Virtual Desktop Resource Profile.

For more information, refer to KB17066 - Configuring VMware View Manager profile.
Problem or Goal
The following error message is displayed, when users click any available Virtual Desktop:

Error message: Access is denied




Pulse Secure client side debug log:
00222,09 2011/06/03 12:52:00.369 3 pstacuser dsTermServ.exe dsTermServProxy p2712 tCC8 dsWorkerThread.cpp:1006 - 'DSPORTMAPCONNECTION' [conn=02ac6190] connection failed for host 192.168.1.111:3389, Software caused connection abort

VMware view event log:
User PSTAC-12\PSTACuser attempted an un-brokered connection to this machine and was not allowed due to view policy
Cause
The root cause of issue is due to the AllowDirectRDP=false parameter configured in the VMware Agent.

When AllowDirectRDP is set to false in the VM connection server, the direct access to the VDI pools is disallowed. The VM admin disables this option to force all the traffic to go through the Connection Server.
Solution
The VM admin has to enable the Direct connection to desktop option.


Related Links
Attachment 1 
Created ByData Deployment

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