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KB25451 - Network Connect error message: 'The Network Connect session timed out. (nc.windows.apps.23790)'

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Last Modified Date7/31/2015 4:52 AM
Synopsis

When there is an IP address change at the client side and then users attempt to connect with the Network Connect (NC) client, an error message is logged. This article discusses the error message and provides a procedure for enabling the roaming session under User roles.

Problem or Goal

The following error message is generated when users connect with the Network Connect client:

 

The Network Connect session timed out. (nc.windows.apps.23790)

Cause

 The notification from the user access log is as follows:

user1(Realm)[role] - 2011/12/09 09:52:57 - SA6000B - Remote address for user user1/Employee changed from 65.nn.nn.nn to 206.nn.nn.nn. Access denied.

This issue occurs when there is an IP address change at the client side.

Another possible cause is that the user has multiple Network Interface Cards (NICs) enabled and connected to the network (e.g., wired and wireless) and the source IP is changing between them; see Solution for more info.

 

Solution

This issue can be resolved by enabling the roaming session under User roles.

Go to User roles > Session options and select the Enabled radio button for Roaming session under User roles:



If this is not viable due to security policies, etc. then the reason why the source IP is changing needs to be investigated and corrected.  

One possible cause is that the user has multiple Network Interface Cards (NICs) enabled and connected to the network (e.g. wired and wireless) and the source IP is changing between them; disabling all but one of the NICs will allow only its configured IP address to only be used and the NC connection will succeed.
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Created ByData Deployment

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