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KB40370 - Error: Signing Certificate File is empty or has an invalid format when import a Signing certificate for SAML Auth Server

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Information

 
Last Modified Date11/4/2016 4:17 PM
Synopsis
This article describes an issue where importing a signing certificate for a SAML auth server prompts with "Error: Signing Certificate File is empty or has an invalid format" and steps to resolve this issue.
Problem or Goal
When importing the signing certificate for a SAML auth server, the following error message may occur:
 
Error:  Signing Certificate File is empty or has an invalid format.
Cause
This issue occurs due issues with the certificate format.
Solution
To confirm the issue, open the certificate file in a text editor and ensure the format look similar to example below:
 
-----BEGIN CERTIFICATE-----
MIICEjCCAbegAwIBAgIQVqo/naD+hZ1DGQ4AGQK/2DAKBggqhkjOPQQDAjBVMRMw
...
EJpC/2xY7tkL6rcsoxLj6bvWlQIhAJUeySO01b1hQPPRyQalp4yJG/bq9B7QBehi
KHzJzLMA
-----END CERTIFICATE-----

The file should conform to the following format:
  • File start with "-----BEGIN CERTIFICATE-----"
  • Each line has 64 characters and a line return at the end of each line
  • File ends with "-----END CERTIFICATE-----"


Workaround:


Pulse Secure recommends to import the metadata file from the IDP to the PCS device.  This will included the signing certificate file and other important information to the PCS device.  This does avoid potential human error during the configuration process between the IDP and SP.
Related Links
Attachment 1 
Created ByK. Kitajima

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