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KB40479 - PPS/PCS appliance will not connect to a Pulse One server during registration

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Information

 
Last Modified Date3/9/2017 10:32 PM
Synopsis
This article describes an issue where PCS/PPS device is unable to connect to Pulse One server during registration.
 
Problem or Goal
An administrator of a PPS/PCS appliance is attempting to register that device with Pulse One and fails.
Cause
This issue occurs when one of the following conditions are met:
  • ​PCS/PPS device is unable to resolve FQDN for api.pulseone.net
  • Network connectivity issue between PCS/PPS device and api.pulseone.net
Solution
To help root cause the following issue, please perform the following steps:
  1. Review the EVENT logs on the PPS/PCS appliance for any error messages that may indicate the reason for the failed registration. If no EVENT logs are visible relating to Pulse One, refer to Step 2.
  2. Navigate to Troubleshooting > Tools > Commands.  Select PING from the COMMAND dropdown menu.
  3. In the Target server field, enter : api.pulseone.net (or the FQDN of your Pulse One appliance)
  4. Select the INTERNAL PORT. 
  5. Select the INTERNAL PORT in the VLAN dropdown menu.
  6. Click OK.

The following output should appear:
PING api.pulseone.net (54.152.131.100) from 10.10.1.175 : 56(84) bytes of data.

--- api.pulseone.net ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 19000ms


Operation complete
 

If the device is unable to resolve api.pulsesecure.net, please review the DNS settings on the PCS/PPS appliance and verify that the DNS server is operational.  As a test, please use 8.8.8.8.  This is the Google public DNS server.

Note:

  • Pulse One will not respond to ICMP packets and so it is normal for the PINGs to timeout.  
  • In PPS 5.3/5.2 and PCS 8.2/8.1, the appliance will communicate via the INTERNAL port only.  In later builds, there is a preferred network interface drop-down menu that will allow you to use the management port rather than only the internal.  Note that the management port must be enabled for this option to be available.

If the device is able to resolve api.pulsesecure.net, verify connectivity between the PCS/PPS and api.pulsesecure.net on all firewall policies for tcp port 443.

The cloud instance of Pulse One is hosted in AWS (Amazon Web Services) and will have multiple IP addresses for load balancing purposes.  Consult your firewall documentation to determine how often it resolves hostnames in its firewall rules.  You may forced to allow HTTPS outbound traffic from the appliance to <ANY> destination. 

Related Links
Attachment 1 
Created ByCraig Brauckmiller

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