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KB40720 - Pulse Secure Desktop client remains in "Connect Requested" with Pulse 5.2R7 and 5.3R1

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Last Modified Date6/28/2017 4:40 AM
Synopsis
This article describes an issue where the Pulse Secure Desktop client remains in "Connect Requested" with Pulse 5.2R7 and 5.3R1.
Problem or Goal
With Pulse Secure Desktop client 5.2R7 and 5.3R1, any connection attempted from the connection list will remain in Connect Requested status and will not connect.  If the end user clicks Cancel to disconnect then attempts to connect again, the same behavior will occur.
Cause
This issue occurs due to a software defect in Pulse Desktop client 5.2R7 and 5.3R1 that prevents a connection from initiating due to a task that is unable to complete in the background.  This issue occurs when any one of the following conditions are met:
  • A user manually deletes a connection from the Pulse client connection list.
  • Pulse is configured with existing connections and the connection set is updated using a pulsepreconfig file that deletes a connection from the connstore.dat file and replaces it with a different connection.  (A connection is deleted if the existing connection GUID value is different from the connection GUID value being pushed to the client.)  
  • A user connects to a PCS device and the connection GUID does not match the GUID in the client's connstore.dat file for that connection.

When connection GUID's do not match the following behavior will occur:
  1. Pulse client will make a connection to the PCS device.
  2. PCS device will send the connection set details to the client.
  3. Pulse client will evaluate all connection GUID's received from the PCS device.
  4. Pulse client will delete all connection GUID's that exist in the local connstore.dat file, but do not exist in the response from the PCS device.  If the current connection being used is deleted, this will cause the Pulse client to immediately move to a Disconnected state.
When the end user attempts to connect again, the status of the connection will remain at Connect Requested.
Solution
To resolve the issue, ensure all connection GUID's are identical across all Pulse Connect Secure devices.  Pulse Secure strongly recommends to keep all connection GUID's identical across all devices to avoid the deletion of any connections.  For more information, refer to KB28914 - Pulse Secure Desktop Client does not receive new or updated connections after connecting to PCS gateway.

To resolve this issue, please upgrade to Pulse Desktop Client 5.3R2 and above.

Workaround:

  • For Windows, users can restart the Pulse Service after the connection is deleted
  • For macOS, users can reboot the machine after the connection is deleted


 
Related Links
Attachment 1 
Created ByK. Kitajima

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