Reset Search
 

 

Article

KB40759 - Pulse Secure Appliance (PSA Series) compliant with FIPS 140-2 standard

« Go Back

Information

 
Last Modified Date2/16/2018 8:04 PM
Synopsis
This article provides details about compliance of PSA series with FIPS 140-2 standard (level 1)
Problem or Goal
Cause
Solution
Pulse Secure's PCS and PPS series of appliances are compliant with FIPS 140-2 (level 1) standard starting with the versions listed below.   This information is also noted in the release notes documents of the below mentioned software versions.

For Pulse Connect Secure on the PSA series, the minimum software version to meet the compliance are the following:
  • 8.2R8 (or later version of 8.2Rx)
  • 8.3R3 (or later version of 8.3Rx)
  • 9.0R1 (or later version of 9.0Rx)

For Pulse Policy Secure on the PSA series, the minimum software version to meet the compliance are the following:
  • 5.3R8 (or later version of 5.3Rx) 
  • 5.4R3 (or later version of 5.4Rx)
  • 9.0R1 (or later version of 9.0Rx)
More details regarding the Cryptographic Module Validation Program are available at the NIST webpage.
Related Links
Attachment 1 
Created ByRuchit Sheth

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255