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KB41028 - Pulse Mobile for iOS is prompting "The server is not responding" after authentication to OKTA Identity Provider (IDP)

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Information

 
Last Modified Date10/23/2017 9:42 PM
Synopsis
This article describes an issue where Pulse Mobile for iOS fails to launch a tunnel and prompts "The server is not responding" after authenticating to OKTA IDP.
Problem or Goal
After the end user enters their credentials, the following error message will be prompted:
The server is not responding
In the PulseSecurePluginApp.log, the following entries will appear:
20170918165931.478168 Pulse Mobile[p2245.t1027] info Found iFrame, mainDocumentURL(https://XXX.okta.com/discovery/iframe.html) 
!= requestURL(https://XXX.okta.com/login/login.htm..(LoginManager.m:559)
...
20170918165941.583768 Pulse Mobile[p2245.t1027] info shouldHandleRequest called for: https://XXXX.okta.com/.. (LoginManager.m:276)
20170918165941.585212 Pulse Mobile[p2245.t1027] error WebView failed to load with error: Frame load interrupted (LoginManager.m:583
Cause
This issue occurs due to iframe restrictions with the OKTA login page.

This issue is applicable only to Pulse Mobile for iOS when OKTA IDP login page is utilized.
Solution
This issue has been fixed in Pulse Mobile 6.7.0

Workaround:
  • Launch using the Safari browser only instead of the Pulse client
Related Links
Attachment 1 
Created ByK. Kitajima

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