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KB43632 - Pulse desktop client installation/upgrade fails on Windows with error: "There is a problem with this Windows installer package. A program required for this install to complete could not be run."

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Last Modified Date11/2/2018 3:08 PM
Synopsis
This article describes an issue where the Pulse client fails to install on Windows clients with error: "There is a problem with this Windows installer package. A program required for this install to complete could not be run."
Problem or Goal

When installing or upgrading the Pulse Secure Desktop Client on Windows the installation fails and the following error message is displayed: 

Error 1721. There is a problem with this Windows Installer package. A program required for this install 
to complete could not be run. Contact your support personnel or package vendor.

Screenshot of error:

User-added image

The error will be recorded in the Windows MSI log as follows:

MSI (s) (0C:28) [09:49:47:088]: Product: Pulse Secure -- Error 1721. There is a problem with this Windows 
Installer package. A program required for this install to complete could not be run. 
Contact your support personnel or package vendor. Action: exe_imm_StopJuniperPulseTray, 
location: C:\Program Files (x86)\Common Files\Juniper Networks\JamUI\, 
command: "C:\Program Files (x86)\Common Files\Juniper Networks\JamUI\pulse.exe" -stop
 
To run the installer and obtain the MSI Verbose Log, execute the following command from the command prompt.
msiexec /i C:\<path to Pulse msi> /l*v C:\Logfile

Pulse versions affected:
This issue can occur when upgrading to a version of Pulse client with rebranded file directories for "Pulse Secure" where an older version has been installed on the client PC that used the "Juniper Networks" directories.  
Cause
The issue is known to occur under the following conditions with regards to a previous installation of Pulse: 
  • The folder  "C:\Program Files (x86)\Common Files\Juniper Networks\JamUI\"  has been deleted but the rest of the directory path is still present.
  • The file "C:\Program Files (x86)\Common Files\Juniper Networks\JamUI\pulse.exe" has been deleted but the other files in the JamUI folder are still present. 
Solution
To resolve this problem, please upgrade to one of the following releases:
  • Pulse Secure Desktop client 5.3R5 and above
  • Pulse Secure Desktop client 9.0R2 and above 

It is not necessary to upgrade the Pulse Connect Secure (server-side) device to resolve this issue. If upgrading the Pulse client is not an immediate option, the following workarounds can be used to fix the issue:

Workaround 
  1. From the Control Panel > Programs and Features, uninstall the Juniper Networks Pulse client before installing the newer version.  (When prompted to save configuration data during the uninstall, click Yes to save the existing connection set so that it is imported to the upgraded Pulse client.)
  2. If step #1 fails, or as an alternative option, download the older Pulse client installer from my.pulsesecure.net Download Center and run this installer again to fix the missing file/folder components.
  3. Run the new version of the Pulse installer again.
Related Links
Attachment 1 
Created ByRafal Gwozdek

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