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KB43672 - PCS/PPS devices registered and connected to Pulse One (Cloud Solution) sporadically generate messages for "Pulse One Notification Channel Status changed"

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Last Modified Date8/30/2018 9:34 PM
Synopsis
This article describes a message generated in the event logs of a PCS/PPS device registered to a Pulse One Cloud Solution that indicate: "Pulse One Notification Channel status changed.." 

Reported intermittent appliance event log entries such as  "Pulse One Notification Channel status changed from in progress to success..." then  followed by "Pulse One Notification Channel status changed from success to error..", then it repeats when connected to Pulse One Cloud.
Problem or Goal

PCS/PPS devices registered and connected to Pulse One Cloud Solution intermittently generate the following messages in the event log:

Pulse One Notification Channel Status changed from in progress to success: Host api.pulsesecure.net
 
Pulse One Notification Channel Status changed from success to error. Host api.pulsesecure.net
 
Pulse One Notification Channel Status changed from in progress to success: Host api.pulsesecure.net

(Screenshot of messages in log)

Error seen

Cause
This issue is caused by the Pulse One server resetting the Websocket connection on a REST failure.  When this occurs, the client, or PCS/PPS device, closed the connection which causes "ping-pong" behavior between the PCS/PPS client and Pulse One server. 
Solution
A fix to keep the Websocket open, and not close and open a new socket, for REST failures that recover immediately was implemented in  the following PCS/PPS releases:

PCS 8.3R5 and up
PCS 9.0R1 and up
PPS C5.4R5 and up
PPS C9.0R1 and up

 
Related Links
Attachment 1 
Created ByFelipe Acusa

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