Reset Search
 

 

Article

KB43768 - Support for macOS Mojave (10.14) / Safari 12 and known issues

« Go Back

Information

 
Last Modified Date12/27/2018 10:55 PM
Synopsis
This article provides compatibility details of macOS Mojave (10.14) / Safari 12 and known issues.
Problem or Goal
  • Pulse Secure official support for macOS Mojave 10.14.
  • Apple's announcement of 32-bit app compatibility alert starting with macOS High Sierra 10.13.4.
  • What's new in Safari 12 and how these changes affect Pulse Secure products.
Cause
Solution

Pulse Secure has qualified macOS Mojave 10.14 with the following releases:

  • Pulse Connect Secure 8.3R7 and above
  • Pulse Connect Secure 9.0R3 and above
  • Pulse Policy Secure 9.0R3 and above 
  • Pulse Secure Desktop 9.0R3 and above
macOS Mojave 10.14 is compatible with Pulse Secure Desktop client 9.0R2.1.

Qualified Platform: The platforms listed as qualified have been systematically tested by the Pulse Secure Quality Assurance department as part of this release.

Compatible Platform: The platforms listed as compatible have not been systematically tested by our QA department in this release; however, Pulse Secure expects that the Pulse functionality will work based on testing of previous releases and knowledge of the platform.

Note:  Software downloads are only available to Pulse Secure administrators with a valid service contract.  End users should contact their Pulse Secure administrator or IT Help Desk to obtain the latest software.

64-bit applications on macOS
  • 64-bit support for Pulse Desktop Client, Host Checker and Pulse Secure Application Launcher (PSAL) was added in the officially supported releases mentioned above.

Known Limitations:
  • Due to NPAPI plug-in removal from Safari 12 (in macOS 10.12.6, macOS 10.13.6 and macOS 10.14), Pulse Secure Java-based applications such as JSAM and Java RDP Hob Applet will not launch via Safari browser.  
  • When launching a 32-bit Pulse Secure application (i.e. PDC 5.3) on macOS High Sierra starting with version 10.13.4, a one-time alert will be displayed that the "App is not optimized for your Mac".  This does not prevent the application from running and will not affect the functionality of the Pulse client.
  • Pulse Desktop Client for macOS does not support Dark mode on Mojave.  If user switches to Dark mode, the Pulse user interface remains unchanged.

Known Issues:

IssuePR #Fixed InKBID

Pulse UI connection details are blackened out with Pulse Desktop client Mac O SX Edition on macOS Mojave

PRS-3647869.0R2.1
 
KB43905
With Pulse for Mac OS X 9.0.2 on macOS Mojave, Host Checker fails to complete with error "Host Checker is not installed properly".PRS-3683209.0R3 
End user is not able to launch HOB applet with Safari 12 using the Java for Remote Desktop LauncherPRS-3692599.0R3 / 8.3R7KB43984 
Related Links
Attachment 1 
Created ByRajkumar Tamilarasan

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255