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KB43851 - Original DNS settings are not properly restored on the physical adapter after the tunnel is destroyed with Pulse Secure Desktop client

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Last Modified Date10/19/2018 3:07 PM
Synopsis
This article describes an issue where the original DNS settings are not properly restored on the physical adapter after the tunnel is destroyed with the Pulse Secure Desktop client.
Problem or Goal
When the tunnel destruction occurs with the Pulse Secure Desktop client, the original dns setting on the physical adapter are not properly restored.  When this problem occurs, the end user may not be able to resolve any domain names as the tunnel DNS server may not be accessible outside the corporate network.
Cause
This issue occurs due to a failure in the SetDNSServerSearchOrder WMI (Windows Management Instrumentation) class returns an error 96 (Unable to notify DNS Service) during the tunnel creation process.  If the conditions occurs, Pulse Secure Desktop client does not properly make a backup of the original DNS setting and the original DNS setting are not properly restored during the tunnel destruction.

There are a number of reasons why the WMI class may return this error message in the fixed version the following message is considered a successful operation, instead of a failure, and will continue to make a backup of the original DNS settings.
Solution
To resolve this problem, please upgrade to the following releases: (This is a client-side fix only and does not require the server OS to be updated.)
  • Pulse Secure Desktop 5.3R6 and above
  • Pulse Secure Desktop 9.0R2.1 and above 
Note: The fix only requires an upgrade of the Pulse Secure Desktop and does not impact the Pulse Connect Secure (server-side) code.
Related Links
Attachment 1 
Created ByGourinath Diojode

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