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KB43873 - End users are receiving "User Input Timed out (Error:1382)" when smartcard certificate is used with the Pulse Desktop Client embedded browser

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Last Modified Date9/17/2019 5:41 PM
Synopsis
This article describes an issue where end users are receiving an error message of "User Input Timed out  (Error:1382)" when smartcard certificate is used with Pulse Desktop Client embedded browser.
Problem or Goal
When an end user is connecting with Pulse Desktop Client (PDC) 9.0.1 (9.0R1) to 9.0.2 (9.0R2) with the embedded browser feature enabled, no login prompt will appear and after 2 minutes, the error message will appear:
User Input Timed out  (Error:1382)
Cause
This issue occurs due to Pulse Desktop Client (9.0.1 to 9.0.2) sets the embedded browser window with an 'always on top' property and the PIN prompt is unable to be displayed over it.

A Pulse Desktop Client embedded browser was added in Pulse Desktop 9.0R1 to allow integrated SAML authentication without requiring an external browser to be launched.   If a smart card reader is used to provide a client certificate for authentication then when the PIN prompt is presented it is hidden behind the embedded browser and cannot be accessed as the browser cannot be minimized or moved and ALT+TAB does not bring the PIN prompt to the foreground.
Solution
To resolve this issue, please upgrade to Pulse Desktop Client 9.0.3 (9.0R3) and above as the 'always on top' property has been removed for the embedded browser.
Related Links
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Created ByMatthew Spiers

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