Reset Search
 

 

Article

KB44113 - Pulse iOS client : Unable to connect with proxy PAC using Pulse Secure Mobile client for iOS 7.1.2.78829

« Go Back

Information

 
Last Modified Date4/16/2019 10:52 PM
Synopsis
This article describes an issue where Pulse Secure Mobile client for iOS is unable to connect to the Pulse Connect Secure (PCS) appliance when a proxy PAC file is enabled on the client
Problem or Goal
The issue will be encountered with the following configuration:
  • Pulse Secure Mobile client for iOS 7.1.2.78829 client is used.
  • Proxy PAC file is used where proxy logic and rules are based on FQDN

The following error is recorded in Pulse Secure Mobile client for iOS logs :
Network extension[p316.t771] info Sending request for https:///danahome/mobile_params.cgi 
Network extension[p316.t771] error Session connection for https:///dana/home/mobile_params.cgi failed with 
error: Error Domain=NSURLErrorDomain Code=-1001 "The request timed out."
Cause
The issue occurs due to the Pulse Secure Mobile client for iOS 7.1.2.78829 design change from resolving FQDN first to IP Address first.  If an external proxy PAC file is used to reach Pulse Connect Secure appliance and PAC file does not have the logic/exception for IP Address resolution, the Pulse Secure Mobile client for iOS fail to connect to Pulse Connect Secure appliance.
Solution
To resolve this issue, the following configuration needs to be configured on the PAC file:
  • Add the IP address of the Pulse Connect Secure node(s) to the proxy exception list along with the FQDN (fully qualified domain name/host) of the Pulse Connect Secure appliance to the proxy exception list
Related Links
Attachment 1 
Created Byjai laisram

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255