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KB44113 - Pulse iOS client : Unable to connect using Pulse Secure Mobile client for iOS 7.1.2.78829 & above

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Last Modified Date4/16/2019 10:52 PM
Synopsis
This article describes an issue where Pulse Secure Mobile client for iOS 7.1.2.78829 & above is unable to connect to the Pulse Connect Secure (PCS) appliance.
Problem or Goal
The issue will be encountered under below conditions :
  • Pulse Secure Mobile client for iOS 7.1.2.78829 client and above is used.
  • Proxy PAC file is used where proxy logic and rules are based on FQDN.
  • Intermediate Firewall device is blocking IP based connections to the PCS.

The following error is recorded in Pulse Secure Mobile client for iOS logs :
Network extension[p316.t771] info Sending request for https:///danahome/mobile_params.cgi 
Network extension[p316.t771] error Session connection for https:///dana/home/mobile_params.cgi failed with 
error: Error Domain=NSURLErrorDomain Code=-1001 "The request timed out."
Cause
The issue occurs due to the Pulse Secure Mobile client for iOS 7.1.2.78829 & above design change from resolving FQDN first to IP Address first.  If an external proxy PAC file is used to reach Pulse Connect Secure appliance and PAC file does not have the logic/exception for IP Address resolution or firewall is blocking connections via IP, the Pulse Secure Mobile client for iOS fail to connect to Pulse Connect Secure appliance.
Solution
To resolve this issue, the following configuration needs to be done :
  • If PAC file is used,add the IP address of the Pulse Connect Secure node(s) to the proxy exception list along with the FQDN (fully qualified domain name/host) of the Pulse Connect Secure appliance to the proxy exception list
  • Make sure the firewall device is not blocking IP based connections to the PCS.
Related Links
Attachment 1 
Created Byjai laisram

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