Reset Search
 

 

Article

KB44243 - Host Checker fails after upgrading to ESAP version to 3.4.3 or higher on macOS endpoints

« Go Back

Information

 
Last Modified Date11/13/2019 12:43 AM
Synopsis
This article describes an issue where Host Checker fails after upgrading to ESAP version to 3.4.3 or higher on macOS endpoints.
Problem or Goal
After upgrading Host Checker to ESAP version 3.4.3 or higher on macOS endpoints, the following error message will appear via the Pulse Desktop Client:
Endpoint is out of compliance (Error: 1122)

The following is a generic error message and the debug log will need to be reviewed to determine the problem.  The following log entries will appear:
root dsAccessService OpswatIMC p0818 t1A03 OpsInterface.cpp:1492 - 
'EsapOpswatSDKV4' Failed to load the Opswat V4 SDK waapi module : 93 :
....
root dsAccessService OpswatIMC p0818 t1A03 OpsIMC.cpp:154 - 
'receiveMessage' Failed to initialize Opswat SDK
Cause

This issue occurs due to a compatibility issue with certain libraries which could not be unloaded properly by the macOS operating system. After further investigation with Apple, the following libraries were updated for notarization support in macOS 10.15.

The following change occurred in ESAP 3.4.3.

Solution
If the problem occurs, Apple has suggested to apply the workarounds (below), which is a one time occurrence, to resolve the issue.

Once workaround is applied, when upgrading to future ESAP releases, it would not be required to reboot the machine (which restarts the Pulse secure service to properly unload and load the libraries) again as the libraries would have been upgraded.

Workaround 1:
  1. Reboot the Mac Book to fix the issue. Rebooting restarts the Pulse secure service.
Workaround 2:
  1. Uninstall the Pulse Desktop Client
  2. Reboot the MacBook
  3. Manually install the Pulse Desktop Client
  4. Try connecting to the Pulse Connect Secure device again.



Special Consideration Needed When Upgrading Pulse Desktop Client (PDC):

When considering upgrading the Pulse Desktop Client version, ESAP package is included as part of the Pulse Desktop Client installer package.  When upgrading to any version of Pulse Desktop Client 9.1R2 and below, this does include a ESAP version below 3.4.3 and would cause the reoccurrence of this issue. Pulse Secure strongly recommends only upgrade to Pulse Desktop 9.1R3 and above.

Related Links
Attachment 1 
Created ByShubham Goel

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255