Reset Search
 

 

Article

KB44255 - After upgrading Pulse Connect Secure and Pulse Policy Secure 9.1R2, client application fail to launch via Internet Explorer.

« Go Back

Information

 
Last Modified Date9/8/2019 3:07 PM
Synopsis
After upgrading Pulse Connect Secure and Pulse Policy Secure to 9.1R2, client applications. such as Pulse Secure Terminal Service client, Host Checker, etc., fails to launch properly with Internet Explorer.
Problem or Goal
This issue occurs under the following conditions :
  • PCS / PPS was upgraded to 9.1R2
  • End user is using Internet Explorer to launch client components (i.e Standalone Host Checker, Terminal Services, WSAM, JSAM, Network Connect, Pulse Desktop Client, etc.)
This issue does not affect the following:
  • PCS / PPS 9.1R1 and below
  • macOS endpoints are not impacted
  • Windows end users using non-Internet Explorer browser (i.e. Chrome, Firefox, etc)
Cause

This issue occurs due to a failure in the signature check of any Pulse Secure client component when launched via Internet Explorer.  In the debug log, the following message will occur:

Not signed by trusted entity  

unsigned application [C:\Users\.\AppData\Roaming\Pulse Secure\Setup Client\PulseSetupClient.exe] 
detected.  

DSInvokeSetupClient - 'DSInvokeSetupClient::invokeSetupClient()' ERROR: launchSetupClient() failed
Solution
The fix is tentative for 9.1R3 (end of October).

Workaround:
  • Use an alternate browser such as Chrome or Firefox.
  • Rollback and upgrade to 9.1R1.
Related Links
Attachment 1 
Created BySumanto Chakraborty

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255