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KB44430 - Constant High CPU seen on PCS (Pulse Connect Secure) even after Disconnecting HTML5 Connections.

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Last Modified Date4/12/2020 6:29 PM
Synopsis
This article describes a scenario where a Constant High CPU is seen on the PCS device even after Disconnecting HTML5 Connections.
Problem or Goal
HTML5 Access is a client-less solution to access Remote Desktops using Remote Desktop Protocol (RDP), or to connect to internal server hosts using Telnet protocols, or to communicate over an encrypted Secure Shell (SSH) session.

Sometimes a constant High CPU is observed on the PCS device with the following Symptoms :
  • This issue gets triggered in situations where too much of Output/Media is generated by RDP/SSH/Telnet Sessions.
  • The CPU remains high until the system services are restarted or PCS rebooted.
  • This affects only HTML5 Connection Type.
Cause
The connections to the backend remaining in the CLOSE_WAIT state even after the connection are disconnected.
 
Solution
This issue is resolved in the PCS 9.1R5 release & above and can be downloaded from https://my.pulsesecure.net/

Workaround – Please restart System services (Maintenance -> System -> Platform -> Restart Services) during off Business Hours to remove the Stale Session and to bring down the PCS CPU.
 
Related Links
Attachment 1 
Created ByRaghu Kumar

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