How to fix Pulse Desktop Client (PDC) 9.1R6 Installation Issue on non-English Windows 10 X64 version (10.0.19041.xxx)?
This article describes a workaround to fix an installation issue of Pulse Desktop Client (PDC) 9.1R6 on non-English Windows 10 X64 version (10.0.19041.xxx).
Problem or Goal
An installation error occurs on attempting to install the Pulse Desktop Client 9.1R6 on non-English Windows 10 X64 version (10.0.19041.xxx). The below error is displayed:
Note:This error does not apply to
macOS
Prior versions of Pulse Desktop Client
Cause
This issue occurs due to translation problems on non-English platforms.
Solution
The solution for this issue will be available in Pulse Desktop Client 9.1R7 and available to download via https://my.pulsesecure.net
To workaround this issue in Pulse Desktop Client 9.1R6, you need to follow the below steps:
Admin Users
Navigate to Computer Management > System Tools > Local Users & Groups > Groups
Create a Group called "Users" (In English)
Non-Admin Users
Admin must add the non-admin user to the "Users" (In English) group
Note: For this to work, the Pulse Installer service must be already installed on the Windows End-Point