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KB44559 - Host checker fails with Error "Host checker didn't get installed properly. Your computer doesn't meet requirements" upon upgrade to Pulse Desktop Client 9.1R8.

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Last Modified Date9/15/2020 7:10 PM
Synopsis

Host checker fails with Error "Host checker didn't get installed properly. Your computer doesn't meet requirements" upon upgrade Pulse Connect Secure or Pulse Desktop Client to 9.1R8.

This article describes an issue where Host Checker fails with Error "Host checker didn't get installed properly. Your computer doesn't meet requirements" upon upgrade Pulse Connect Secure or Pulse Desktop Client to 9.1R8.
Problem or Goal
For Host checker configurations that have “Cache Cleaner” enabled, it is observed that Host Checker fails with Error "Host checker didn't get installed properly. Your computer doesn't meet requirements" upon upgrade Pulse Connect Secure or Pulse Desktop Client to 9.1R8.

This issue occurs irrespective of the ESAP, Pulse Connect Secure (PCS / Pulse Policy Secure (PPS) versions used. 

This issue can be ascertained by checking the following log entry in the Pulse Client logs.

 
0191,10 2020/07/24 17:15:59.613 1 SYSTEM PulseSecureService.exe HostCheckerService p9784 t46C FTNCCCore.c:125
 - 'TnccHandleException' An IMC threw an exception! Core dump created. Terminating.

 
Cause
The issue occurs due to a bug in the code.
Solution
The issue is fixed in 9.1R8.2 PCS and PDC versions.

Note : Both PCS and PDC need to be upgraded to 9.1R8.2 for the fix.

To workaround the issue, please disable “Cache Cleaner” at Realm & Role Level on PCS/PPS by following the steps below: 

Realm Level

  • Navigate to Users > User Realms
  • Click on the desired Realm name.
  • Select  Authentication Policy > Host Checker
  • Uncheck "Evaluate Policies" & "Require and Enforce" against Cache Cleaner Policy
  • Click on "Save Changes". 
  • Repeat the above steps for all other User Realms. 

User-added image

Role Level :
  • Navigate to Users > User Roles
  • Click on the Role name.
  • Select General > Restrictions > Host Checker
  • Ensure that "Cache Cleaner Policy" is not listed under the "Selected Policies" as shown below.
  • Repeat the above steps for all other User Roles. 
User-added image
 
Note: If the workaround doesn't help, please open a Support Case along with Pulse Detailed Logs. 
Related Links
Attachment 1 
Created ByRaghu Kumar

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