This article describes about the error "Server Disabled" when licensing client tries to lease licenses from licensing server.
Problem or Goal
When the "Pull state from server" button is clicked, located at System > Configuration > Licensing > License Summary on the License Client, the following error is generated:
"Failed to fetch lease information from the server. Please check the event logs and the admin logs for more information".
Cause
Checked for generated errors in the Event log of Licensing Client: System()[] - License Server Protocol Error: Code=(0x61) Error="Server Disabled"
This issue can be more predominant on Virtual Licensing Server.
The above error is caused because the "Manages license members for 'x' years" has become inactive on Licensing Server, as a result of break in communication between Licensing Server and pcls.pulseone.net.
The VLS checks-in (heartbeats) with the PCLS every 8 hours. This allows us to monitor and prevent cloning of VLS instances.
If the Licensing Server License becomes inactive, then the Licensing Server cannot lease appropriate licenses.
Solution
Licensing functionality will get disabled if there is no connectivity to PCLS for more than 24 days.
To reactivate VLS, customer must re-enter the authcode (it can be an existing authcode) to establish connection with PCLS. After this, License Server functionality will get restored.
Once the VLS is restored, admin can try to click on "Pull State From Server" on the Licensing Client to re-establish the communication with Licensing Server in order to participate in leasing.