Reset Search
 

 

Article

KB43801 - FAQ on NetworkExtension API Framework being used in Pulse iOS Client 7.0.0

« Go Back

Information

 
Last Modified Date7/9/2018 11:28 PM
Synopsis
This Article provides responses to frequently asked questions about the NetworkExtension Framework being added in Pulse Secure iOS Client 7.0.0

NOTE : Please also refer KB43813 - Certificate authentication fails with error "Missing or Invalid Certificate" after installing or upgrading to Pulse Mobile for iOS 7.0.0

 
Problem or Goal
Cause


 
Solution
Q: What is NE ( NetworkExtension ) Framework based Pulse Secure iOS Client ?

A: Prior to the release of Pulse for iOS 7.0.0, the Pulse client was developed using VPN framework provided by Apple which is now deprecated.  Starting with Pulse for iOS 7.0.0 the new Apple VPN framework called "NetworkExtension" will be used.  
 
For more details about NetworkExtension refer to https://developer.apple.com/documentation/networkextension.

Q: Which Pulse Secure iOS client version is based on NetworkExtension Framework?

A: Starting with Pulse iOS client 7.0.0, the Pulse client for IOS will be using NetworkExtension Apple VPN framework.Pre-release notification has been sent out for the release ETA.The Pulse iOS client 7.0.0 is scheduled to be released by the 17th of August.

Q: What are the advantages of using the NetworkExtension based Pulse Secure iOS client?

A: The NetworkExtension framework contains APIs that can be used to customize and extend the core networking features of iOS and macOS.  This will allow Pulse Secure to leverage the latest Apple framework for more reliable VPN connectivity and also to support the latest features in iOS.
 
Q: Can customers enroll to test the beta version of the NetworkExtension Framework based Pulse iOS client?


A: The beta testing is closed as the Pulse iOS client 7.0.0 is scheduled for release by 17th August.

Q: Which iOS versions support the NetworkExtension Pulse iOS client? 

A: NetworkExtension Framework based Pulse iOS Client is only supported in iOS 9.0 and above.  The Pulse Secure iOS client 7.0.0 version will also be compatible with iOS 12.0 which is yet to be released.

 
Related Links
Attachment 1 
Created ByLokesh T K

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255