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KB45698 - Client upgrade fails from Pulse Secure 9.1.X series to Ivanti Secure Access 22.X series (MDM setup)

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Last Modified Date2/1/2023 6:52 PM
Synopsis
Problem or Goal
End users are receiving pop up during the upgrade process (jamf wants access to control "pulse secure")
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Cause
This issue is caused due to the Ivanti installer trying to update the System Extension, Which requires a privilege.
This issue started occurring after PSAM support for MAC with system Extensions from 9.1R15 PDC.
Solution

To fix the issue kindly follow the below steps.

1) Add 'Removable System Extensions' to the payload

Step 1:  Select Computers > Configuration Profiles >New.
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Step 2:  Create a configuration profile to remove Ivanti system extensions.

>> Enter a Display Name for the configuration profile.
>> Select System ExtensionsConfigure.
>> (Optional) Enter a Display Name.
>> In System Extension Types, select Removable System Extensions.
Enter the Team Identifier for the pulse secure (3M2L55NZLB).
In the REMOVABLE SYSTEM EXTENSIONS section, Add the Bundle Identifier for pulse secure system extensions (net.pulsesecure.PulsesecureFirewall, net.pulsesecure.firewall.systemextension) and Save the removable system extension that you configured.

2) Save the configuration profile.
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Related Links
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Created ByR Vignesh Vigu

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