Reset Search
 

 

Article

KB22878 - Untrusted errors after installing a Comodo certificate on a Pulse Connect Secure device

« Go Back

Information

 
Last Modified Date8/2/2015 10:31 PM
Synopsis

Error messages such as sec_error_unknown_issuer or untrusted error are generated on a web browser after a Comodo certificate is installed on a Pulse Connect Secure device. This error message occurs when Mozilla Firefox is unable to chain up to a trusted Certificate Authority. This article provides an explanation and a procedure to resolve this issue.

Problem or Goal

The following error may occur on the Mozilla Firefox web browser when accessing the Junos Pulse Secure Access log in page after installing a Comodo device certificate.

Error: 'sec_error_unknown_issuer'

However, when the same Pulse Connect Secure login page is accessed using Internet Explorer, no error message is generated and the login page is displayed correctly.



 
Cause

This error message occurs when Mozilla Firefox is unable to chain up to a trusted Certificate Authority.

 

Solution

To resolve this issue, perform the following steps:

  1. Navigate to https://sslanalyzer.comodoca.com and enter the Pulse Connect Secure device URL.
  2. Confirm whether 'Trusted by Microsoft' and 'Trusted by Mozilla'  is Yes.  If No, this means that the proper Comodo intermediate certificate authorities are not installed on the Pulse Connect Secure device. Refer to Step 3.
 
  1. Log in to the Pulse Connect Secure device admin page.
  2. Navigate to System > Configuration > Certificates > Device Certificate.
  3. Click Intermediate CAs.
  4. Click Import CA Certificate.  
  5. Click Browse and select the corresponding intermediate certificate authority.
  6. Repeat Steps 6 and 7 if there are multiple intermediate certificate authorities in the chain.    

Note: Comodo intermediate certificate authorities can be found at https://support.comodo.com/?_m=downloads&_a=view&parentcategoryid=1. If you are unsure which certificates are needed, please refer to the Comodo installation instructions received via e-mail or contact Comodo support for further assistance.

Related Links
Attachment 1 
Created ByData Deployment

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255