Reset Search
 

 

Article

KB43717 - Pulse Secure Desktop client fails to connect on Windows 10 machines due to error "Failed to setup virtual Adapter (Error 1205)" when Windows Reliability Tool (prior to 10.0.14393.10020) is installed.

« Go Back

Information

 
Last Modified Date4/14/2018 12:59 AM
Synopsis
This article describes an issue where the Pulse Secure Desktop client fails to connect on Windows 10 due to error "Failed to setup virtual Adapter (Error 1205)" when Windows Reliability Tool prior to 10.0.14393.10020 is installed.
Problem or Goal
End users running Windows 10 (build 1607 and 1703) are unable to connect to the Pulse Connect Secure (PCS) device due to the following error message:
Failed to setup virtual adapter. (Error:1205)
User-added image

Symptoms:

  • Pulse client will run without issues for a period of time then suddenly fail without any changes made to the system.
  • Once the issue occurs, uninstalling and reinstalling the Pulse client temporarily resolves the issue.
  • When the issue occurs, the Device Manager (using Show Hidden Devices) shows that the Juniper Networks Virtual Adapter Manager is installed correctly under Network adapters section, however, the Juniper_Networks_Virtual_Adapter_01 is listed under Other devices with a question mark icon.
            User-added image
  • When viewing the Properties > General tab of the Juniper_Networks_Virtual_Adapter_01 adapter, the following driver information will be displayed:
There are no compatible drivers for this device
  • When viewing the Properties > Events tab of the Juniper_Networks_Virtual_Adapter_01 adapter,  the event "Device deleted" will be displayed one or more times.
User-added image
Cause
This issue is caused by the Update for Microsoft Windows 10 (KB4023057) that was released in February 2018 that updated the reliability tool to version 10.0.14393.10019 which causes the Pulse cache INF file for the Pulse Secure virtual adapter to get removed under certain conditions.  This results in the virtual adapter driver to not be recognized any longer which causes Pulse client connections to fail with the error "Failed to setup virtual Adapter (Error:1205)". 

Known Windows versions affected:
Windows 10 versions 1607 and 1703 that have Microsoft KB4023057 with an install date of February of 2018.
Solution
To root cause the issue, verify the following conditions:
  1. Go to C:\Program Files\rempl and right click on the file remsh and select Properties.
  2. Select the Details tab and check the Product version of the Reliability Tool.  If the version is below 10.0.14393.10020 then the system will be impacted.
User-added image
 
  1. Under Control Panel > All Control Panel Items > Programs and Features check the date when KB4023057 was installed/updated. 
User-added image

If the Update for Windows 10 (KB4023057) is present, and has an install date of Feb 2018 then the Windows client may be affected by this issue.  (There are cases where KB4023057 is has an install date of February, but the reliability tool version is 10.0.14393.10020.  These systems would not be affected.)  If the update is present but was installed in March or April of 2018 then the Windows client will not be impacted by this issue.  If the reliability tool version is 10.0.14393.10020 or later, and the system is impacted, please collect the Pulse logs and open a case with support.
 

Workaround:

If all conditions apply, Pulse Secure recommends to take the following actions:
  1. Uninstall the Pulse client
  2. Apply the workaround provided in Microsoft support article 4098563. The workaround will completely block the reliability tool from running. To do this, run the following commands:
takeown /f "C:\Program Files\rempl" /r /d y
icacls "C:\Program Files\rempl" /grant administrators:F /t /q
icacls "C:\Program Files\rempl" /deny system:F /t /q
  1. Reinstall the Pulse client

 


FAQ:
Q.  Does Pulse Secure have the latest release of KB4023057 that can be packaged and pushed out to clients as a solution?
A.  No.  As per the Microsoft support page with details about KB4023057, this update is not offered from the Microsoft Update Catalog and cannot be downloaded as a separate installer.


 

Related Links
Attachment 1 
Created ByKshitij Gupta

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255