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KB43759 - Pulse Desktop Client 9.0 installation on macOS 10.13 High Sierra shows a message "System Extension Blocked "

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Information

 
Last Modified Date6/25/2018 5:03 PM
Synopsis
This article describes an information about a message "System Extension Blocked" being shown while installing Pulse Desktop Client 9.0 on MacOS 10.13
 
Problem or Goal
 
When installing the Pulse Desktop client on macOS 10.13 (also known as macOS High Sierra), below pop-up might appear during installation.

 
" System Extension Blocked . A program tried to load new extensions signed by Pulse Secure LLC. If you want to enable these extensions, go to the Security & Privacy System Preference pane "

Below is the screen shot for the pop-up alert message.


User-added image


If user did not allow Pulse Secure LLC service from Security & Privacy System, then Pulse Secure service will be turned off until user allows it.
 
Note: This approval UI is only present in the Security & Privacy preferences pane for 30 minutes after the alert. Until the user approves the KEXT, future load attempts will cause the approval UI to reappear but will not trigger another user alert.
For more information please refer following apple like https://developer.apple.com/library/content/technotes/tn2459/_index.html 



 
Cause
This issue is caused by a change to the kext installation procedure in macOS High Sierra. When an application tries to install a kernel extension (also known as a kext) , MacOS prompts the user to authorize the installation of the kext. In earlier versions of Mac OS, the kext was installed automatically without the user being prompted.
 
Solution
The steps below are required to authorize the kext and utilize the Pulse Desktop Client for Mac:
 
Authorize kext in System Preferences
  1. ​Click the Apple menu at the top left of your desktop.
  2. ​Click System Preferences.
  3. ​Click Security & Privacy.
  4. Click the lock to make changes.
  5. Click the General tab.
  6. Under Allow apps downloaded from, select:
    App Store and identified developers
  7. Look for the message that says:
    System software from developer "Pulse Secure LLC" was blocked from loading. 
  8. ​Click Allow to enable the extension.
  9. Close the Security & Privacy window.
The kernel extension has been authorized.

User-added image
 

Troubleshooting Information :

======================

During installation of the Pulse Desktop client, one can check the install log (/var/log/install.log) to confirm whether the Pulse kernel extension is loaded successfully or not as below:
 
When kext loading is successful after installation:
./postinstall: /Library/Extensions/PulseSecureFirewall.kext kextload is successful.
 
When kext is blocked due to Secure Kernel Extension Loading:
./postinstall: /Library/Extensions/PulseSecureFirewall.kext kextload is blocked due to Secure Kernel Extension Loading.
 
When kext could not be loaded with an appropriate status code:
./postinstall: /Library/Extensions/PulseSecureFirewall.kext kextload is unsuccessful with errorCode $status.
 
The kext loading status can also be checked using `kextstat` command in Terminal and checking for “net.pulsesecure.PulseSecureFirewall” entry after installation

 
Related Links
Attachment 1 
Created ByLokesh T K

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