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KB43939 - Host Checker caching failed checks denies users full access

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Last Modified Date12/26/2018 7:05 PM
Synopsis
This article provides details on why Host Checker caches failed check results.
Problem or Goal
When Host Checker caching is enabled clients who fail a Host Check have their negative results cached for the configured period and are unable to gain full access after remediating the causes of the failed Host Check.
Cause
Host Checker Caching is a feature introduced in PCS/PPS 9.0R1, it can be configured to cache results for the specified number of days if specific Role(s) are assigned or if any Role is assigned.

When the client fails the Host Check, if they are assigned a remediation Role then this would trigger the negative results to be cached if the option  Cache results if any of the roles is assigned is enabled.
Solution
To avoid negative results being cached specify only the Roles which are assigned to users if they successfully pass Host Checker under Cache results only if any of the selected roles are assigned

If a user has negative results cached then to allow the user to re-run Host Checker the feature has to be disabled to clear the database on the PCS/PPS by the administrator and then re-enabled to allow caching to.resume.  This will also remove all other cached results, both positive and negative, so all subsequent users will need to run Host Checker once again to populate the cache database.

Also note that the cache database uses the client MAC address as the endpoint identifier so if a user is connecting from a different device Host Checker would need to run on it and the cache table updated with the results for that endpoint.
Related Links
Attachment 1 
Created ByMatthew Spiers

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