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KB44102 - Receiving "Failed to retrieve API key. Document Error: Not Found" or "Failed to retrieve API key. Invalid credentials." when configuring Infranet Enforcer

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Last Modified Date4/4/2019 2:07 PM
Synopsis
When configuring a Palo Alto Network (PAN) Firewall as a new Infranet Enforcer, the Pulse Policy Secure (PPS) administrator may be entering the correct service account credentials, but the error will continue to occur.
Problem or Goal
When configuring an Palo Alto Network (PAN) Firewall as a new Infranet Enforcer, the following error message may appear:
Failed to retrieve API key. 
Document Error: Not Found
OR
Failed to retrieve API key. 
Invalid credentials.

This may occur when entering the correct credentials for the service account created on the PAN firewall.
Cause
This issue can occur when one of the following conditions are met:
  1. Incorrect credentials are entered in the Pulse Policy Secure (PPS) administrator console compared to the PAN firewall service account.
  2. Service account created on the PAN firewall has the following special characters are not allowed by Palo Alto:
    • # (pound)
    • & (ampersand)
    • + (plus)
Solution
To resolve this issue, please confirm the service account username and password created on the PAN firewall and ensure the disallowed special characters do not exists in the password.
Related Links
Attachment 1 
Created ByK. Kitajima

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