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KB44370 - Pulse Workspace : Android Device enrollment fails with the message "There was a network error. Please obtain a new registration key and try again".

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Last Modified Date2/19/2020 8:19 PM
Synopsis
This article describes an issue where Android users are unable to enroll their device in Pulse Workspace.
Problem or Goal
New Android user Device enrollment fails with the message "There was a network error. Please obtain a new registration key and try again".
  • The issue is observed on versions 2.0.1903.1 & 2.0.1904 (Both On-premise and Cloud).
  • The issue occurs irrespective of the Android version. 
The issue doesn't impact : 
  • iOS Users.
  • The Android devices already enrolled to Pulse Workspace. 
Cause
This is due to a Sync issue on PWS during Google Registration caused by a change on the Google side. 
Solution
This issue is resolved in Pulse One version 2.0.1904.1 & later. And, the fix is available for download via https://my.pulsesecure.net.

Note: There are no workarounds for this issue. 

The Cloud (Saas) instance is already upgraded to 2.0.1904.1. 
Related Links
Attachment 1 
Created ByRaghu Kumar

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