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KB44471 - Receiving "No license keys" when applying or downloading Virtual License Server (VLS) license

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Last Modified Date5/15/2020 1:31 AM
Synopsis
This article describes an issue where administrator will receive "No license keys" when applying or downloading Virtual License Server (VLS) license keys.
Problem or Goal
When attempting to download or install Virtual License Server (VLS) license keys (PS-LIC-VLS-SVR-XYR), the following message will appear:
No license keys

Additionally, the admin log will state the following message:
License download server provision response - 
'{"return_code":0,"return_message":"OK",
"license_keys":["fubar fubar fubar fubar fubar"]}'
Cause
The issue occurs due to the SKU is not compatible for PSA-V instances.
Solution
To determine the type of instance, refer to the first 5 characters of the Licensing Hardware ID under System > Configuration > Licensing.
 
User-added image
 
  • If the Licensing Hardware ID is VASPH, this is a PSA-V appliance.
  • If the Licensing Hardware ID is VASPM, this is a VLS appliance.

If a PSA-V appliance was created, please delete the current appliance.  During the creation of the virtual appliance via the serial console, it will prompt if the appliance will be a license server, please ensure to enter yes and try to claim the license again.
Related Links
Attachment 1 
Created ByK. Kitajima

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