Reset Search
 

 

Article

KB45268 - SAML Consumer received and processed 'Post', Status: 'FAILURE: No valid assertion found in SAML response' DetailedLogs:Assertion Signature Verification Failed.

« Go Back

Information

 
Last Modified Date6/24/2022 8:31 AM
Synopsis
This article describes about Error "SAML Consumer received and processed 'Post', Status: 'FAILURE: No valid assertion found in SAML response' DetailedLogs:Assertion Signature Verification Failed." seen under user access logs when certificate is renewed manually for Azure.
Problem or Goal
The event is noticed when we have renewed the Azure Sign-in certificate manually. If the response signing certificate is not updated properly. The user will fail to login.

Under User Access Logs:
User-added image
End User:
User-added image
Cause
This is occurred when SAML Signing Certificate is manually renewed.

To verify the issue is due to the signing certificate.

1. Login to Azure Portal> Enterprise Applications> Open the PCS application> SSO> Edit- SAML Signing Certificate> See the certificate status> Note the thumbprint>
User-added image

Goto PCS Server> Auth Server> Open the SAML Server> Under SSO> Note the Thumbprint(thumbprint should match the active one in Azure SAML signing page)

User-added image


 
Solution
PCS will only detect one signing certificate and if more than 1 is seen, this error is noticed. Kindly remove the inactive certificate from Azure portal and save changes.

Update the metadata file by downloading it manually or use remote option seen under 
System> Configuration>SAML> click on Metadata name> Use option remote or local accordingly and save changes which will resolve the issue.
Related Links
Attachment 1 
Created ByZaeem Quadir

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255